Click on image action doesn’t work in ScenarioBuilder

Hi, I created a new scenario in ScenarioBuilder but it keeps failing in click on an image action. I tried to recapture the image but it didn’t work. It finds the image but it doesn’t click. I can manually click on the button but it doesn’t work when I play in ScenarioBuilder. I’m stuck… :slightly_frowning_face: Anyone ever had a similar issue?

@ipetrov What action do you use? If you use “Click on Image”, try to use “Find Image” with “Mouse Move and Click” action. Sometimes this combination works better for some buttons.

Thank you for your reply. I tried both actions but still same issue. It’s a little bit strange because it works for some steps but then it stops clicking. I tried to delete the actions and add them again to the scenario but it didn’t help.

Have you tried to repeat the action? or double-clicking on the button? Maybe you can try to use the OnFailure Goto action to click again. Like below:

@ipetrov Can you share the steps of your scenario? what is the application that your test?

Thanks guys for your help. I tried to use the label and repeat the action but I still have the clicking issue. :frowning: my scenario is simple, just trying to open computer management and then trying to connect to another computer,…

I think I know what the issue is. Based on the steps (that opens “Computer management”, then click on a menu) , Sometimes, for security reasons, the user doesn’t have permission to open certain windows or click on them. So they need to run ScenarioBuilder.exe as an administrator.

Go to ScenarioBuilder installation folder and right click on ScenarioBuilder.exe->Properties->Compatibility -> Run this program as administrator.

It will show the User Account Control and click YES, after that try again.

3 Likes

I tried your solution a few days ago and forgot to update here. It worked perfectly! Thank you.