Process flow fails with a black screenshot error in robot in Automai RPA

Hello, I am trying to run a process flow from RPA, and the process is failing immediately. If I look at the Reports tab, the failure image shows the screen as black. It seems my robot is offline, however the rWorker is running in the machine since I can see it online and available. Any idea what the issue might be?

Hey Tim,

Have you tried to restart the rWorker process? or restart the machine if it’s possible? Maybe the communication between the Manager and robot has broken.

@amit_singh I stopped and started robot again.No luck! It looks rWorker is connected with the RPA. The issue happens when I disconnect from the machine before playing the process flow. If I remain connected to the machine and run the process flow, it runs fine.

@TimC I assume Automai Sessions Controller service is not running in the machine. You can check it under the services to see if it’s up or not.

@TimC Based on your provided information, there can be 2 reasons:

1. As @Paul mentioned, maybe the Automai Sessions Controller service is not running in the rWorker machine. Please try the following steps:

A. Go to the machine where rWorker is installed, open the Task Manager and go to “Services” tab
B. Check if “Automai Sessions Controller” service is up. If it’s stopped, try to start it. If it gives you an error for incorrect log on. Then you need to put the correct log on information for the service.
If this is the case, please do the below:
a. Open Services and find Automai Sessions Controller service.
b. Right click on it and open Properties.
c. Open Log On tab and enter credentials (username and password used to login to the Windows machine where Sessions Controller is installed).

2. Maybe you are trying to run the process flow before the robot session is active because you mentioned you disconnected from the robot and tried to start the process flow.
Let me explain how the process works:

When you install rWorker along with Sessions Controller, Sessions Controller creates a connection file for that robot worker, if the session of the robot gets disconnected, logged off or locked, Sessions Controller checks this and uses that connection file to activate the session for the robot, so the robot can run in order to execute processes. Hope this makes sense.

Now if you disconnect from the machine, Sessions Controller will try to activate the session within a minute. I assume maybe you tried to run the Process flow before the session was connected.
If this is the case and the “Automai Sessions Controller” service is running, then try to disconnect from the machine, go back to the Manager and try to run your Process flow after one min.