Robot window shows black in Manager and doesn’t get connected

I have RPA and rWorker installed on a server. While I am using the browser in my PC, the rWorker shows green but the session is black in Robots page. I restarted the rWorker and the server but it didn’t help. Any ideas?

Hi Julia,

I think you need to check your network configuration. It might be a firewall issue. Maybe you should open some ports :slightly_smiling_face:

I checked the ports. All looks good. I am able to see the robot desktop when I am inside the cloud server but it shows black when I use my browser. I tried other browsers, all have the same issue.

You might need to open the port that shows the desktop (32700) in your cloud network (i.e. AWS security group).

Hi @juliac,

Welcome to the Community!

If the robot is online but the session shows black (doesn’t show the user’s desktop) in the “Robots” page, you can check and try the below steps:

  1. Connect to the rWorker machine, end the SSConsole.exe process from the Task Manager (if it is running) and start it again from this location: “…\Automai\rWorker[user]\SSConsole” folder.
  2. Go to “Robots” page, open the robot session in a new tab and make sure the port number that it is using in the address is open and not blocked by firewall or as suggested, you may need to add it to the cloud security group.
  3. Go to “Robots” page and click “List view”. Hover over the desired robot and click “Select" to edit it. Put the public IP address of the instance in the “External IP” field and refresh the page.

@Alex Hi, I added the external IP and I am able to see the robot session. I wasn’t aware of this option. Good to know. :wink: