“This page can't be displayed“ error message when launching RPA Manager

I just downloaded and installed Automai RPA on a new server but it seems something is wrong since I am not able to launch RPA Manager. Can anyone help me?

Here is what I get when launching RPA:

@newn33 Have you tried to launch it using a different browser? I usually do not use IE because of its security settings!

Hi Natalie,
All Automai services are running? I had similar issue once and one of the services was stopped. When I started it, the page showed up.

Thank you for the help. I tried to open RPA with Chrome and Firefox but no luck!

@Nav90vp I don’t see any Automai services under Services section. I will try to uninstall and install again.

I uninstalled and installed again but still no services?! Any ideas?

@newn33 Just a thought! Are you running the setups using a admin user? Maybe there is a security issue…

@newn33 Hi Natalie, it looks like the services are not being installed automatically during the installation process. You can try to install them manually by following the steps in this article.